Author

Topic: Bitcoin in Ubuntu 10.04 (Read 18696 times)

founder
Activity: 364
Merit: 3077
June 22, 2010, 12:39:43 PM
#13
It's too late now for feature changes to 0.3, but I'll add that to the post-0.3 to do list.  I never would have noticed that if you hadn't pointed it out.
full member
Activity: 210
Merit: 100
June 22, 2010, 02:17:52 AM
#12
Yeah, r89 works as expected for me. It doesn't seem to have any problems creating or removing icons, but I'm using XFCE, so that might be the difference.

In addition, there's a difference between standard behaviour for tray icons in Windows and Linux. In most Linux apps, clicking the tray button while the app's window is open will cause it to close again. I personally like that better than the Windows default, where a single click does nothing once the main window is displayed. Is there any chance that feature might get added to the Linux version?
founder
Activity: 364
Merit: 3077
June 21, 2010, 11:45:56 PM
#11
On Ubuntu 10.04 it wouldn't remove the taskbar button cleanly, so I made it leave it there.

But now that you mention it, it's probably better to have the feature, even if it's messy, than not to have it, though it may confuse a few people when the taskbar button temporarily stays around but disappears if you click on it.

Updated SVN.

Thanks for testing.
full member
Activity: 210
Merit: 100
June 21, 2010, 10:04:14 PM
#10
Satoshi, that definitely made it look better for me, but now Bitcoin won't minimize to tray in Ubuntu 10.04. The proper check box is checked, but it just minimizes to my taskbar like always.
founder
Activity: 364
Merit: 3077
June 21, 2010, 01:20:21 PM
#9
Bitcoin looks ugly in Ubuntu's new default theme. It seems that some, but not all of the theme settings are being picked up. The unselected file menu should have light text with a dark background, but it incorrectly has light text with a light background. They're similar enough that it's unreadable on my display. It should be fixed before the next stable release.
This is now fixed in the SVN version.
1) Menu bar default color.
2) Balance bar not a different color.
3) Background behind bitcoin address and balance now the same color as toolbar.

I checked all the standard themes and it seems reasonable with all of them.

Ubuntu minimize,maximize,close buttons to the right:
gconf-editor
apps->metacity->general
button_layout=menu:minimize,maximize,close

They've got it awfully buried considering 9 out of 10 users are used to having it on the right.
newbie
Activity: 13
Merit: 1
June 21, 2010, 09:28:02 AM
#8
I don't thinks it looks ugly.
You can change the buttons back to the right side if you wish, just google for it. Smiley
full member
Activity: 202
Merit: 108
GCC - Global cryptocurrency
June 21, 2010, 09:18:09 AM
#7
I think the default theme in 10.04 makes everything look ugly.  And why are mini/maxi/close on the left side and not the right?  That's really annoying.
newbie
Activity: 13
Merit: 1
June 21, 2010, 05:08:36 AM
#6
I'm new, but it works fine here. It's version 0.2 though.

http://i45.tinypic.com/1z5knb8.jpg
sr. member
Activity: 252
Merit: 255
June 14, 2010, 02:27:20 AM
#5
The problem is with the default theme. You're screen shot is not the default theme.
full member
Activity: 132
Merit: 101
June 13, 2010, 11:49:46 PM
#4
I don't see any problems here, running 10.04 myself now!
sr. member
Activity: 252
Merit: 255
June 09, 2010, 08:35:13 AM
#3
I didn't feel like editing images, so I just took a few partial screenshots.

Edit: I just added a screenshot of the file menu in gcalctool as an example of how the menu should be displayed.
full member
Activity: 132
Merit: 101
May 23, 2010, 05:18:46 PM
#2
Can you upload a screenshot? It'd help out great.
sr. member
Activity: 252
Merit: 255
May 23, 2010, 12:28:12 PM
#1
Bitcoin looks ugly in Ubuntu's new default theme. It seems that some, but not all of the theme settings are being picked up. The unselected file menu should have light text with a dark background, but it incorrectly has light text with a light background. They're similar enough that it's unreadable on my display. It should be fixed before the next stable release.
Jump to: