Author

Topic: EXCEPTION: 22DbRunRecoveryException (Read 11033 times)

newbie
Activity: 3
Merit: 0
July 13, 2010, 04:24:03 PM
#5
The Bitcoin dir wasn't created at all. I tried creating the folder myself, I checked the permission of %APPDATA%, nothing worked.

I've tried running as admin too. Embarrassed
full member
Activity: 199
Merit: 696
July 13, 2010, 02:50:16 PM
#4
Maybe it's the UAC stuff - like perhaps the %APPDATA%/Bitcoin dir was created while it was running as administrator but now it's running normally?  Maybe you could try running it as administrator to see if it's related to that.
newbie
Activity: 3
Merit: 0
July 13, 2010, 02:48:27 PM
#3
That's where %appdata% resolves to (I've tested).
legendary
Activity: 860
Merit: 1015
July 13, 2010, 02:41:32 PM
#2
C:\Users\USERNAME\AppData\Roaming\Bitcoin

That's where the wallet.dat and the block database is stored.
Maybe you can find the bug there.

Win7 64-Bit here and no problems with running Bitcoin 0.3.
newbie
Activity: 3
Merit: 0
July 13, 2010, 07:27:09 AM
#1
Hi! I'm running bitcoin in Linux without any problems, but I've tried installing it on Windows and I can't get it to run.

The error is:
Code:
EXCEPTION: 22DbRunRecoveryException
DbEnv::open:DB_RUNRECOVERY:Fatal error, run database recovery

It happens both on the zip version and the installed.

I tried going to %appdata% and there was no bitcoin folder. Tried creating one, nothing, tried copying the wallet.dat file from the Linux version, nothing.

I'm running Bitcoin 0.3.0 on Windows 7 (32bit).

Thanks for your help!
Jump to: