Author

Topic: freenet and cpu priority (Read 8449 times)

administrator
Activity: 4228
Merit: 8647
August 17, 2010, 09:22:35 PM
#7
Freenet already runs at low priority (nice 10).

You can change Bitcoin's priority as it starts. Right click the Bitcoin shortcut in the "startup" folder in the start menu. Click "properties". Change the "target" to this:
Code:
C:\Windows\System32\cmd.exe /c start "Bitcoin" /LOW /MIN "C:\Program Files\Bitcoin\bitcoin.exe"
Red
full member
Activity: 210
Merit: 106
August 17, 2010, 11:33:01 AM
#6
Could this be a competition of programs wanting to run a the "lowest" priority? Where bitcoin just competes less hard.

For example freenet wants to run at -10 priority but bitcoin only tries to run at -9 priority.
 
sr. member
Activity: 252
Merit: 255
August 17, 2010, 09:50:34 AM
#5
It's quite difficult to generate a block right now. If you've got lots of other things running, then from a practical perspective I think it would be better to get not generate bitcoins. My guess is that it's not so much the process priority that's the problem as much as just the processor thrashing between tasks because it's got so much going on. The more tasks you have running concurrently, the more important it is to leave a portion of your total CPU below the maximum in order to keep your system running smoothly.

If you've got a specialty, you could offer your services in the Marketplace section or if you've got unwanted electronics or other item, you could offer to sale it. Trading for or buying bitcoins is probably easier, faster and cheaper than generating them on your computer.
legendary
Activity: 1246
Merit: 1014
Strength in numbers
August 16, 2010, 05:26:25 PM
#4
You have multiple cores I guess? I just change affinity in task manager to keep 2 cores not working on bitcoin, I never slowdown now.

I don't think. An athlon 2200+ 1.51Ghz and 1.5Go of ram.



Oh, sorry to assume. It just seemed like a lot of things running. But still my understanding is that Bitcoin is supposed to throttle down automatically, but it often doesn't for me, so I do like I said.
newbie
Activity: 2
Merit: 0
August 16, 2010, 03:46:39 PM
#3
You have multiple cores I guess? I just change affinity in task manager to keep 2 cores not working on bitcoin, I never slowdown now.

I don't think. An athlon 2200+ 1.51Ghz and 1.5Go of ram.

legendary
Activity: 1246
Merit: 1014
Strength in numbers
August 16, 2010, 03:00:39 PM
#2
You have multiple cores I guess? I just change affinity in task manager to keep 2 cores not working on bitcoin, I never slowdown now.
newbie
Activity: 2
Merit: 0
August 16, 2010, 01:44:30 PM
#1
Hello,

I installed your soft one month ago.

It is said, it "only" the free cpu. That's right, when i want to watch a divx etc.. no problem, no lag.

But recentely i installed freenet, this mean too other soft : fuquid, thaw, frost, fms.

And i have problems when bitcoin is active, freeze.

If i "control+alt+del" to set the priority level at very low for bitcoin, it solves the problem.

On this panel control, priority cpu level for bitcoin is "normal".

Of course, the problem could be from one of other softs running.

But, it could be very usefull on window xp to select the level of cpu priority you want in setting tool. Because all run auto when window run.
and the best is not to have to set manually each time.

For exemple, at the same time I run :

-freenet
-emule
-frost
-fms
-fuquid
-mozilla.
-bitcoin
-watching a divx.

When i have a freeze, set cpu priority from normal to low for bitcoin, solve the problem. And bitcoin is still running.

Thanks for your work and your idee, a great idee.

In hope the next update will solve this.

cheers ^^.
Jump to: