Author

Topic: Help running bitcoin in a Debian Lenny headless machine (Read 11042 times)

full member
Activity: 168
Merit: 100
Firstbits: 175wn
thanks for your help.

My host tells me that your reference to squeeze is for debian 6.x and apparently I'm running debian 5.x, so it's a no go.

is this just an anomaly with this particular version of bitcoin? i.e. would waiting for 0.3.25 solve this problem or would the problem be ongoing until my OS is upgraded?

Yep, squeeze is the latest stable debian version (just released in February).

The problem is with how the precompiled binaries were compiled. I doubt that whoever builds the precompiled binaries will change this in the future, so waiting for 0.3.25 wouldn't fix it.

Unless you want to compile bitcoin yourself, it looks like you're going to have to wait for an upgrade to squeeze.
hero member
Activity: 812
Merit: 1000
The precompiled binaries need squeeze (current stable) or later.

You can either upgrade to squeeze, or compile bitcoind yourself. Also note that on occasion someone will post a precompiled version on the forum that was compiled for older libraries (and works with lenny).

thanks for your help.

My host tells me that your reference to squeeze is for debian 6.x and apparently I'm running debian 5.x, so it's a no go.

is this just an anomaly with this particular version of bitcoin? i.e. would waiting for 0.3.25 solve this problem or would the problem be ongoing until my OS is upgraded?

full member
Activity: 168
Merit: 100
Firstbits: 175wn
The precompiled binaries need squeeze (current stable) or later.

You can either upgrade to squeeze, or compile bitcoind yourself. Also note that on occasion someone will post a precompiled version on the forum that was compiled for older libraries (and works with lenny).
hero member
Activity: 812
Merit: 1000
has anyone successfully done this?  I have been trying for days with no success. 

bumping an old thread... still can't get 0.3.24 working on debian lenny.
jr. member
Activity: 48
Merit: 3
has anyone successfully done this?  I have been trying for days with no success. 
newbie
Activity: 50
Merit: 0
I've got libglib2.0-0 installed.    I believe Debian's libstdc++.so is older than the one bitcoind was compiled with.  Same error here.


hrm. I'm using Squeeze for all of my generation, it seems. You can try upgrading to the testing version of that package.
member
Activity: 111
Merit: 10
I've got libglib2.0-0 installed.    I believe Debian's libstdc++.so is older than the one bitcoind was compiled with.  Same error here.
newbie
Activity: 50
Merit: 0
You need the libglib2.0-0 package. You don't need the dev.
newbie
Activity: 1
Merit: 0
Hello. I want to run bitcoin software in a Debian Lenny headless machine. But I don't know how to do it.
Of course the name of the user and the machine are not real  Wink
First Try
Code:
[email protected]:~/bitcoin/bin/32$ ./bitcoind 
./bitcoind: error while loading shared libraries: libgthread-2.0.so.0: cannot open shared object file: No such file or directory

Second Try
I installed libglib2.0-dev
Code:
[email protected]:~/bitcoin/bin/32$ ./bitcoind
./bitcoind: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by ./bitcoind)
Jump to: