Author

Topic: Issues building bitcoin on Windows 7 (Read 10898 times)

newbie
Activity: 17
Merit: 0
September 05, 2011, 09:31:14 PM
#29
Are you sure the AMI builds have been updated for the latest 0.4 bitcoin release?
member
Activity: 78
Merit: 11
Twitter:@watersNYC
September 05, 2011, 03:01:11 PM
#28
It does still exist, but I am not able to connect to it when I make an instance - I get the "Remote Desktop can't connect to the remote computer for one of these reasons:"

My port is forwarded for 3389, and my remote settings allow connections from computers running any version of remote desktop.
member
Activity: 78
Merit: 11
Twitter:@watersNYC
September 05, 2011, 12:40:18 PM
#27
Does that AMI still exist, and is it compatible with the 4.0 source?
legendary
Activity: 1652
Merit: 1186
Chief Scientist
February 21, 2011, 09:26:14 AM
#26
Oops, sorry-- I forgot to change the admin password.  The correct pw for that instance is:
  penguinsrule


I change the password to match the MinGW VM and updated the AMI:
  ami-d621d2bf    982440761210/BitcoinVC10
Admin password:  bitcoin development

You should change the password as soon as you login or make sure you use a security group that only allows your IP address to access the virtual machine.

newbie
Activity: 12
Merit: 0
February 21, 2011, 05:39:08 AM
#25
Here's the public AMI for the dodgy 0.3.20 VC10 build:
  ami-78cf3c11     982440761210/BitcoinVC10

Great, thanks. I launched an instance and tried logging on as Administrator with the password you gave on this thread, but no dice. Did you set this up with a different password? Or set it up to use auto-generated passwords?
LZ
legendary
Activity: 1722
Merit: 1062
P2P Cryptocurrency
February 20, 2011, 07:34:09 PM
#24
Can I somehow use it on my local computer? Can someone download it?
legendary
Activity: 1652
Merit: 1186
Chief Scientist
February 20, 2011, 02:35:09 PM
#23
Here's the public AMI for the dodgy 0.3.20 VC10 build:
  ami-d621d2bf    982440761210/BitcoinVC10

Bitcoin source is at c:\bitcoin
(all the other dependencies are in the root c:\, too).
Administrator password is:  bitcoin development
newbie
Activity: 12
Merit: 0
February 20, 2011, 11:30:01 AM
#22
I'll uninstall it from the VM and then make the image public; you'll have to download and install (and agree to the license) Visual Studio Express yourself to get it working.

Sure, that wouldn't be a problem for me. Good idea.
legendary
Activity: 1652
Merit: 1186
Chief Scientist
February 20, 2011, 11:03:38 AM
#21
Gavin, do you have / can you make public the image for the dodgy 0.3.20 VC10 build? I'd like to have a look and compare it to my home build to see if I can reproduce that rendering artifact problem. Thanks.

Yes, I have the VC10 VM.  I am hesitant to make it publicly available because it has a copy of Visual C++ 2010 Express installed, and I don't want Microsoft to sue me for redistributing their software without permission.

I'll uninstall it from the VM and then make the image public; you'll have to download and install (and agree to the license) Visual Studio Express yourself to get it working.
hero member
Activity: 756
Merit: 500
February 20, 2011, 09:04:13 AM
#20
Is this to compile a Windows binary much faster than it would on your own PC? e.g. if I did get the compile going I may find myself sitting there for X number of hours (days?) waiting for it to compile but you smart guys do it on EC2 instead...
newbie
Activity: 12
Merit: 0
February 20, 2011, 06:04:05 AM
#19
Gavin,

I found this but I could not find the download link:

http://thecloudmarket.com/image/ami-2edd2e47--bitcoinmingw

Caston, you'll have to sign up to Amazon's EC2 services, and then you can search for the image and launch an instance of it from the online AWS management console.

Gavin, do you have / can you make public the image for the dodgy 0.3.20 VC10 build? I'd like to have a look and compare it to my home build to see if I can reproduce that rendering artifact problem. Thanks.
hero member
Activity: 756
Merit: 500
February 19, 2011, 09:44:58 PM
#18
Gavin,

I found this but I could not find the download link:

http://thecloudmarket.com/image/ami-2edd2e47--bitcoinmingw
legendary
Activity: 1652
Merit: 1186
Chief Scientist
February 19, 2011, 02:20:10 PM
#17
Gavin, is this windows/mingw build environment publicly available?

Yes, it is public Amazon ami-2edd2e47   named  982440761210/BitcoinMinGW

The linux32 and linux64 amis I used to build the linux releases are also public.
hero member
Activity: 756
Merit: 500
February 19, 2011, 11:27:00 AM
#16
I just committed (to git and svn) an updated build-msw.txt
Thanks to m0mchil for putting together a working windows/mingw build environment.

And I'll be making the 0.3.20 build environment virtual machines (for Windows, Linux32, and Linux64, in the Amazon EC2 cloud) public, hopefully, if all goes well, later today.


Gavin, is this windows/mingw build environment publicly available?
legendary
Activity: 1652
Merit: 1186
Chief Scientist
February 18, 2011, 01:50:35 PM
#15
I just committed (to git and svn) an updated build-msw.txt
Thanks to m0mchil for putting together a working windows/mingw build environment.

And I'll be making the 0.3.20 build environment virtual machines (for Windows, Linux32, and Linux64, in the Amazon EC2 cloud) public, hopefully, if all goes well, later today.
hero member
Activity: 756
Merit: 500
February 18, 2011, 11:02:25 AM
#14
Thanks  lzsaver.

I got further much than I did last time... but still so far.. might try again in a week or so.
LZ
legendary
Activity: 1722
Merit: 1062
P2P Cryptocurrency
hero member
Activity: 756
Merit: 500
February 13, 2011, 11:45:30 PM
#12
Hi,

I am trying to compile bitcoin on Windows 7 64-bit with MinGW and I have found the wx, openssl and boost sources but I am still unsure as to what db_cxx.h is and where I can find it.

Please enlighten me.

Thank you,

Chris
member
Activity: 73
Merit: 10
September 30, 2010, 08:07:38 PM
#11
You should include boost libraries via -l (lowcase L) option WITHOUT lib prefix. It's added automagically by linker I guess. For linux build I included:

 -Wl,-Bstatic \
   -l boost_system \
   -l boost_filesystem \
   -l boost_program_options \
   -l boost_thread \

...not mentioning db_cxx and some others.

(is a makefile for g++ with mingw going to be the same as one natively run on linux?)

The makefile for mingw is using -l and the included defaults in the original 0.3.12 makefile looked like:

Code:
LIBS= \
 -l libboost_system-mgw34-mt-d \
 -l libboost_filesystem-mgw34-mt-d \
 -l libboost_program_options-mgw34-mt-d \
 -l libboost_thread-mgw34-mt-d \

So I did a find in the boost directory and was presented with a lot of things that looked similar so I just modified the makefile to match what the find returned...removing the -mgw45-mt-d-1_44 part makes compilation fail. Modifying my makefile too much makes it fail as well, and I don't really want to deviate too far from from what was provided as the default makefile for mingw under windows (I think what I'm doing this far is more or less working because it makes it all the way to program_options before giving me errors).

Also please note that removing 'lib' does not seem to matter, it still gets to the program_options part and fails with the same error messages I posted earlier


For example, if I run
Code:
find . -name "libboost_program_options*" -print
in my source/libraries directory I get all of this:
(output from the mingw shell)

Code:
[username]@Desktop /c/Users/[username]/Desktop/bitcoin-CUDA-svn153-src-gpl
$ find . -name "libboost_program_options*" -print
./boost/bin.v2/libs/program_options/build/gcc-mingw-4.5.0/debug/libboost_program_options-mgw45-d-1_44.dll
./boost/bin.v2/libs/program_options/build/gcc-mingw-4.5.0/debug/libboost_program_options-mgw45-d-1_44.dll.a
./boost/bin.v2/libs/program_options/build/gcc-mingw-4.5.0/debug/link-static/libboost_program_options-mgw45-d-1_44.a
./boost/bin.v2/libs/program_options/build/gcc-mingw-4.5.0/debug/link-static/runtime-link-static/libboost_program_options-mgw45-sd-1_44.a
./boost/bin.v2/libs/program_options/build/gcc-mingw-4.5.0/debug/link-static/runtime-link-static/threading-multi/libboost_program_options-mgw45-mt-sd-1_44.a
./boost/bin.v2/libs/program_options/build/gcc-mingw-4.5.0/debug/link-static/threading-multi/libboost_program_options-mgw45-mt-d-1_44.a
./boost/bin.v2/libs/program_options/build/gcc-mingw-4.5.0/debug/threading-multi/libboost_program_options-mgw45-mt-d-1_44.dll
./boost/bin.v2/libs/program_options/build/gcc-mingw-4.5.0/debug/threading-multi/libboost_program_options-mgw45-mt-d-1_44.dll.a
./boost/bin.v2/libs/program_options/build/gcc-mingw-4.5.0/release/libboost_program_options-mgw45-1_44.dll
./boost/bin.v2/libs/program_options/build/gcc-mingw-4.5.0/release/libboost_program_options-mgw45-1_44.dll.a
./boost/bin.v2/libs/program_options/build/gcc-mingw-4.5.0/release/link-static/libboost_program_options-mgw45-1_44.a
./boost/bin.v2/libs/program_options/build/gcc-mingw-4.5.0/release/link-static/runtime-link-static/libboost_program_options-mgw45-s-1_44.a
./boost/bin.v2/libs/program_options/build/gcc-mingw-4.5.0/release/link-static/runtime-link-static/threading-multi/libboost_program_options-mgw45-mt-s-1_44.a
./boost/bin.v2/libs/program_options/build/gcc-mingw-4.5.0/release/link-static/threading-multi/libboost_program_options-mgw45-mt-1_44.a
./boost/bin.v2/libs/program_options/build/gcc-mingw-4.5.0/release/threading-multi/libboost_program_options-mgw45-mt-1_44.dll
./boost/bin.v2/libs/program_options/build/gcc-mingw-4.5.0/release/threading-multi/libboost_program_options-mgw45-mt-1_44.dll.a
./boost/stage/lib/libboost_program_options-mgw45-1_44.a
./boost/stage/lib/libboost_program_options-mgw45-1_44.dll
./boost/stage/lib/libboost_program_options-mgw45-1_44.dll.a
./boost/stage/lib/libboost_program_options-mgw45-d-1_44.a
./boost/stage/lib/libboost_program_options-mgw45-d-1_44.dll
./boost/stage/lib/libboost_program_options-mgw45-d-1_44.dll.a
./boost/stage/lib/libboost_program_options-mgw45-mt-1_44.a
./boost/stage/lib/libboost_program_options-mgw45-mt-1_44.dll
./boost/stage/lib/libboost_program_options-mgw45-mt-1_44.dll.a
./boost/stage/lib/libboost_program_options-mgw45-mt-d-1_44.a
./boost/stage/lib/libboost_program_options-mgw45-mt-d-1_44.dll
./boost/stage/lib/libboost_program_options-mgw45-mt-d-1_44.dll.a
./boost/stage/lib/libboost_program_options-mgw45-mt-s-1_44.a
./boost/stage/lib/libboost_program_options-mgw45-mt-sd-1_44.a
./boost/stage/lib/libboost_program_options-mgw45-s-1_44.a
./boost/stage/lib/libboost_program_options-mgw45-sd-1_44.a


The only other thing I can maybe think of is that I should be adding .a or .dll to the end of each line...but the ones prior to program_options seem to be doing ok with out it, so I'm still stumped  Huh


In case anyone wants to take a look at the full compilation output up until the errors:
http://pastebin.com/KwaarmD2
This was not done after a fresh make clean because it would be very long, I could however provide that if it would be helpful.
full member
Activity: 185
Merit: 100
September 30, 2010, 12:52:58 PM
#10
You should include boost libraries via -l (lowcase L) option WITHOUT lib prefix. It's added automagically by linker I guess. For linux build I included:

 -Wl,-Bstatic \
   -l boost_system \
   -l boost_filesystem \
   -l boost_program_options \
   -l boost_thread \

...not mentioning db_cxx and some others.
LZ
legendary
Activity: 1722
Merit: 1062
P2P Cryptocurrency
September 30, 2010, 03:31:19 AM
#9
I think you should ask eurekafag about it. He has successfully compiled the CUDA version for Linux. Smiley
member
Activity: 73
Merit: 10
September 30, 2010, 01:11:06 AM
#8
(still given up with MSVC++ for now, just reformatted and don't want to go bloating up my system with visual studio and friends for now...)
This is my attempt to build the source that puddinpop has released... bitcoin-CUDA-svn153-src-gpl

I've made some changes to the makefile to reflect the version of boost that i'm using (1.44) and mingw 4.5 and also to support not-absolute-paths; here is what I'm working with at present:

Code:
# Copyright (c) 2009-2010 Satoshi Nakamoto
# Distributed under the MIT/X11 software license, see the accompanying
# file license.txt or http://www.opensource.org/licenses/mit-license.php.


INCLUDEPATHS= \
 -I"./boost" \
 -I"./db/build_unix" \
 -I"./openssl/include" \
 -I"./wxwidgets/lib/gcc_lib/mswud" \
 -I"./wxwidgets/include"

LIBPATHS= \
 -L"./boost/stage/lib" \
 -L"./db/build_unix" \
 -L"./openssl/out" \
 -L"./wxwidgets/lib/gcc_lib"

WXLIBS= \
 -l wxmsw29ud_html -l wxmsw29ud_core -l wxmsw29ud_adv -l wxbase29ud -l wxtiffd -l wxjpegd -l wxpngd -l wxzlibd

LIBS= \
 -l libboost_system-mgw45-mt-d-1_44 \
 -l libboost_filesystem-mgw45-mt-d-1_44 \
 -l libboost_program_options-mgw45-mt-d-1_44 \
 -l libboost_thread-mgw45-mt-d-1_44 \
 -l db_cxx \
 -l eay32 \
 -l kernel32 -l user32 -l gdi32 -l comdlg32 -l winspool -l winmm -l shell32 -l comctl32 -l ole32 -l oleaut32 -l uuid -l rpcrt4 -l advapi32 -l ws2_32 -l shlwapi

DEFS=-DWIN32 -D__WXMSW__ -D_WINDOWS -DNOPCH
DEBUGFLAGS=-g -D__WXDEBUG__
CFLAGS=-mthreads -O2 -w -Wno-invalid-offsetof -Wformat $(DEBUGFLAGS) $(DEFS) $(INCLUDEPATHS)
HEADERS=headers.h strlcpy.h serialize.h uint256.h util.h key.h bignum.h base58.h \
    script.h db.h net.h irc.h main.h rpc.h uibase.h ui.h noui.h init.h

OBJS= \
    obj/util.o \
    obj/script.o \
    obj/db.o \
    obj/net.o \
    obj/irc.o \
    obj/main.o \
    obj/rpc.o \
    obj/init.o \
    cryptopp/obj/sha.o \
    cryptopp/obj/cpu.o


all: bitcoin.exe


obj/%.o: %.cpp $(HEADERS)
    g++ -c $(CFLAGS) -DGUI -o [email protected] $<

cryptopp/obj/%.o: cryptopp/%.cpp
    g++ -c $(CFLAGS) -O3 -DCRYPTOPP_X86_ASM_AVAILABLE -o [email protected] $<

obj/ui_res.o: ui.rc  rc/bitcoin.ico rc/check.ico rc/send16.bmp rc/send16mask.bmp rc/send16masknoshadow.bmp rc/send20.bmp rc/send20mask.bmp rc/addressbook16.bmp rc/addressbook16mask.bmp rc/addressbook20.bmp rc/addressbook20mask.bmp
    windres $(DEFS) $(INCLUDEPATHS) -o [email protected] -i $<

bitcoin.exe: $(OBJS) obj/ui.o obj/uibase.o obj/ui_res.o
    g++ $(CFLAGS) -mwindows -Wl,--subsystem,windows -o [email protected] $(LIBPATHS) $^ $(WXLIBS) $(LIBS)


obj/nogui/%.o: %.cpp $(HEADERS)
    g++ -c $(CFLAGS) -o [email protected] $<

bitcoind.exe: $(OBJS:obj/%=obj/nogui/%) obj/ui_res.o
    g++ $(CFLAGS) -o [email protected] $(LIBPATHS) $^ $(LIBS)


clean:
    -del /Q obj\*
    -del /Q obj\nogui\*
    -del /Q cryptopp\obj\*
    -del /Q headers.h.gch



So far, calling both 'mingw32-make -f makefile.mingw bitcoind.exe' from cmd.exe or 'make -f makefile.mingw bitcoind.exe' from the MinGW shell are giving me the same problems. It gets as far as the boost_program_options, and then exits with the following errors:

Code:
C:\Users\[username]\Desktop\bitcoin-CUDA-svn153-src-gpl/./boost/boost/program_options/eof_iterator.hpp:75: undefined reference to `boost::program_options::detail::common_config_file_iterator::get()'
obj/nogui/util.o: In function `basic_config_file_iterator':
C:\Users\[username]\Desktop\bitcoin-CUDA-svn153-src-gpl/./boost/boost/program_options/detail/config_file.hpp:147: undefined reference to `boost::program_options::detail::common_config_file_iterator::common_config_file_iterator(std::set, std::allocator > const&, bool)'
C:\Users\[username]\Desktop\bitcoin-CUDA-svn153-src-gpl/./boost/boost/program_options/detail/config_file.hpp:150: undefined reference to `boost::program_options::detail::common_config_file_iterator::get()'
collect2: ld returned 1 exit status
mingw32-make: *** [bitcoind.exe] Error 1

Kind of stuck here at the moment and any help would be appreciated (is it possible something failed when I was building boost?)  Smiley
newbie
Activity: 53
Merit: 0
September 24, 2010, 07:05:30 AM
#7
My CMake version at http://bitbucket.org/dkaparis/bitcoin-cmake/ can build on windows using MSVC, both IDE project and command line nmake. You'll only need CMake.
member
Activity: 73
Merit: 10
September 21, 2010, 08:07:46 PM
#6
I've given up for the time being with VC and have been having a bit more success with MinGW, I will report back if I decide to give VC a try in the future
founder
Activity: 364
Merit: 3077
September 19, 2010, 02:46:46 PM
#5
The lines it's tripping on:
Code:
ERROR extern map mapAddressBook;
ERROR extern CCriticalSection cs_mapAddressBook;
ERROR extern vector vchDefaultKey;
OK extern bool fClient;
OK extern int nBestHeight;


OK extern unsigned int nWalletDBUpdated;
ERROR extern DbEnv dbenv;

So it's acting like nothing is defined, not even map and vector.

Yet, db.h is included by headers.h (and only there, nowhere else) which includes vector, map, util.h and everything before db.h.

Is VC trying to use precompiled headers and screwing it up?  Could there be some leftover precompiled header files in your directory from previously failed attempts that it's finding and using?

There's an installer package now that makes it really easy to install MinGW.  Don't use the latest version 4.5.0, use a few versions back like 4.4.1 (1.908.0) or 1.812.0.  A setup program completely installs everything, it's not hard like it used to be.  I think the only thing I had to do was rename make*.exe something to make.exe.
http://tdm-gcc.tdragon.net/

Off topic, but: It would be nice if someone would hack on getting tcatm's 4-way 128-bit SSE2 code working on Windows.  There's something with MinGW's optimisation, I'm not sure but maybe a problem with 16-byte alignment on the stack, that makes it segfault.  With some fiddling, I was able to get his code to work in a test program, but not in Bitcoin itself for some reason.
member
Activity: 73
Merit: 10
September 16, 2010, 10:48:24 PM
#4
Ok...so trying to build from the commandline with nmake is still giving me the same problems:


Code:
c:\Users\[myusername]\Desktop\bitcoin-0.3.12\src>nmake /f makefile.vc

Microsoft (R) Program Maintenance Utility Version 10.00.30319.01
Copyright (C) Microsoft Corporation.  All rights reserved.

        cl /c /nologo /MDd /EHsc /GR /Zm300 /Zi /D__WXDEBUG__ /DWIN32 /D__WXMSW__ /D_WINDOWS /DNOPCH /I"/boost"  /I"/db/build_windows"
 /I"/openssl/include"  /I"/wxwidgets/lib/vc_lib/mswud"  /I"/wxwidgets/include" /DGUI /Foobj\util.obj util.cpp
util.cpp
c:\users\[myusername]\desktop\bitcoin-0.3.12\src\db.h(15) : error C2143: syntax error : missing ';' before '<'
c:\users\[myusername]\desktop\bitcoin-0.3.12\src\db.h(15) : error C4430: missing type specifier - int assumed. Note: C++ does not support defau
lt-int
c:\users\[myusername]\desktop\bitcoin-0.3.12\src\db.h(16) : error C2146: syntax error : missing ';' before identifier 'cs_mapAddressBook'
c:\users\[myusername]\desktop\bitcoin-0.3.12\src\db.h(16) : error C4430: missing type specifier - int assumed. Note: C++ does not support defau
lt-int
c:\users\[myusername]\desktop\bitcoin-0.3.12\src\db.h(16) : error C4430: missing type specifier - int assumed. Note: C++ does not support defau
lt-int
c:\users\[myusername]\desktop\bitcoin-0.3.12\src\db.h(17) : error C2143: syntax error : missing ';' before '<'
c:\users\[myusername]\desktop\bitcoin-0.3.12\src\db.h(17) : error C4430: missing type specifier - int assumed. Note: C++ does not support defau
lt-int
c:\users\[myusername]\desktop\bitcoin-0.3.12\src\db.h(23) : error C2146: syntax error : missing ';' before identifier 'dbenv'
c:\users\[myusername]\desktop\bitcoin-0.3.12\src\db.h(23) : error C4430: missing type specifier - int assumed. Note: C++ does not support defau
lt-int


Any additional advice would be appreciated...  Undecided


I think that the C4430 error can be ignored by adding a #pragma warning(disable:4430) to headers.h, but the other ones appear to be more serious

It looks like the C2143 is sometimes caused by problems with #includes, but since I am just using the files that were distributed with the source...I would assume all are functional? Maybe it is something about using vs2010 that is causing the problems?
legendary
Activity: 1540
Merit: 1000
September 14, 2010, 03:28:48 PM
#3
You should build using the nmake command from the visual studio command prompt as described in the information distributed with the source.

There's a makefile.mingw, and although I haven't tried yet, I'll probably take a stab at windows building for my cuda miner. Can I not use this?
newbie
Activity: 15
Merit: 0
September 14, 2010, 02:58:07 PM
#2
You should build using the nmake command from the visual studio command prompt as described in the information distributed with the source.
member
Activity: 73
Merit: 10
September 14, 2010, 08:14:25 AM
#1
I've been playing around with visual studio (2010) trying to build bitcoin from the source that is included in the win32 zip archive. I created a new makefile project and imported the makefile, acquired the boost, wxwidgets, and the openssl sources, and a few other files which were reported missing when I would try to build. I got as far as the build log reporting that it needed iostream.h, so I went and found a copy of that from libstdc++. Now, after trying to build with iostream.h located in my includes directory, I am getting loads of errors that look like this:

Code:
1>------ Build started: Project: bitcoin_test, Configuration: Debug Win32 ------
1>Build started 9/14/2010 08:07:14.
1>InitializeBuildStatus:
1>  Touching "Debug\bitcoin_test.unsuccessfulbuild".
1>ClCompile:
1>  util.cpp
1>c:\users\[myusername]\desktop\bitcoin-0.3.12\src\db.h(15): error C2143: syntax error : missing ';' before '<'
1>c:\users\[myusername]\desktop\bitcoin-0.3.12\src\db.h(15): error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
1>c:\users\[myusername]\desktop\bitcoin-0.3.12\src\db.h(16): error C2146: syntax error : missing ';' before identifier 'cs_mapAddressBook'
1>c:\users\[myusername]\desktop\bitcoin-0.3.12\src\db.h(16): error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
1>c:\users\[myusername]\desktop\bitcoin-0.3.12\src\db.h(16): error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
1>c:\users\[myusername]\desktop\bitcoin-0.3.12\src\db.h(17): error C2143: syntax error : missing ';' before '<'
1>c:\users\[myusername]\desktop\bitcoin-0.3.12\src\db.h(17): error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
1>c:\users\[myusername]\desktop\bitcoin-0.3.12\src\db.h(23): error C2146: syntax error : missing ';' before identifier 'dbenv'
1>c:\users\[myusername]\desktop\bitcoin-0.3.12\src\db.h(23): error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
1>c:\users\[myusername]\desktop\bitcoin-0.3.12\src\db.h(23): error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
1>c:\users\[myusername]\desktop\bitcoin-0.3.12\src\db.h(34): error C2143: syntax error : missing ';' before '*'
1>c:\users\[myusername]\desktop\bitcoin-0.3.12\src\db.h(34): error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
1>c:\users\[myusername]\desktop\bitcoin-0.3.12\src\db.h(34): error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
1>c:\users\[myusername]\desktop\bitcoin-0.3.12\src\db.h(35): error C2146: syntax error : missing ';' before identifier 'strFile'
1>c:\users\[myusername]\desktop\bitcoin-0.3.12\src\db.h(35): error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
1>c:\users\[myusername]\desktop\bitcoin-0.3.12\src\db.h(35): error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
1>c:\users\[myusername]\desktop\bitcoin-0.3.12\src\db.h(36): error C2143: syntax error : missing ';' before '<'
1>c:\users\[myusername]\desktop\bitcoin-0.3.12\src\db.h(36): error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
1>c:\users\[myusername]\desktop\bitcoin-0.3.12\src\db.h(36): error C2238: unexpected token(s) preceding ';'

This has happened with 2 different versions of iostream.h (tried changing to in db.h also), and if I remove iostream.h from my includes directory it simply reports that file is missing and doesn't give hundreds of lines of errors like the above. I haven't modified any files at all, I am just trying to get the project to build in a windows environment right now...

I am sort of stuck here and haven't been able to figure out what the problem is. Admittedly I don't entirely know what I'm doing (I don't have a whole lot of experience with C++ in windows), but I was wondering if anyone has any ideas what my problem might be.
Jump to: