Author

Topic: minconf=nnn don't works in CLI? (Read 8362 times)

LZ
legendary
Activity: 1722
Merit: 1062
P2P Cryptocurrency
February 17, 2011, 08:08:24 AM
#9
I think it should be [confirmations] instead of [minconf=1]. Thanks.
sr. member
Activity: 350
Merit: 250
probiwon.com
February 16, 2011, 09:09:02 AM
#8
The help text is misleading; never pass the "foo=" part.

Somebody could teach bitcoin to accept either  getreceivedbyaccount foo 10    or    getreceivedbyaccount address=foo minconf=10

First option is better if you do not intend to use GNU options format '--xxx'. (And it is easier to implement on C.)

But for the convenience of future users make better use a GNU options. Then can be written a good autocomplete for shell.

Quote
... but maybe we should just change how the help text shows default arguments or improve the documentation.
legendary
Activity: 1652
Merit: 1186
Chief Scientist
February 15, 2011, 03:07:14 PM
#7
The help text is misleading; never pass the "foo=" part.

Somebody could teach bitcoin to accept either  getreceivedbyaccount foo 10    or    getreceivedbyaccount address=foo minconf=10
... but maybe we should just change how the help text shows default arguments or improve the documentation.
LZ
legendary
Activity: 1722
Merit: 1062
P2P Cryptocurrency
February 15, 2011, 01:38:25 PM
#6
Will it be fixed for CLI sometime? I tested with 0.3.20 and got the same result.
sr. member
Activity: 350
Merit: 250
probiwon.com
August 05, 2010, 08:41:43 PM
#5
It's a bug with Bitcoin's JSON-RPC client, I think. I get that for all commands with more than one parameter. Try using some other client (JSON-RPC PHP, for example) to do it.

No, console client is better now: https://bitcointalksearch.org/topic/m.7709

I don't think it would be difficult to fix this problem.
sr. member
Activity: 350
Merit: 250
probiwon.com
August 05, 2010, 08:36:48 PM
#4
Code:
[email protected]:~$ ./bitcoin-0.3.8/bin/64/bitcoin getreceivedbylabel mylabel minconf=10
error: type mismatch
[email protected]:~$ ./bitcoin-0.3.8/bin/64/bitcoin getreceivedbylabel mylabel
0.000000000000000

or I did not understand the format of command?
Should be

bitcoin getreceivedbylabel "Your Address" 0

Your label must be in "" if it has a space in it and the next sytax is the minimum number of confirmations to count towards the total.

So if that command spits back 10.00.... for example and you changed the last number to 4000 (meaning, only count transactions that have 4000 confirmations or more) then you might get back a 0.000... for example if you have no transactions with that many confirmations.

Smiley

execve do not let me spoil label with a spaces
sr. member
Activity: 308
Merit: 252
August 05, 2010, 06:57:28 PM
#3
Code:
[email protected]:~$ ./bitcoin-0.3.8/bin/64/bitcoin getreceivedbylabel mylabel minconf=10
error: type mismatch
[email protected]:~$ ./bitcoin-0.3.8/bin/64/bitcoin getreceivedbylabel mylabel
0.000000000000000

or I did not understand the format of command?
Should be

bitcoin getreceivedbylabel "Your Address" 0

Your label must be in "" if it has a space in it and the next sytax is the minimum number of confirmations to count towards the total.

So if that command spits back 10.00.... for example and you changed the last number to 4000 (meaning, only count transactions that have 4000 confirmations or more) then you might get back a 0.000... for example if you have no transactions with that many confirmations.
administrator
Activity: 4228
Merit: 8647
August 05, 2010, 06:32:47 PM
#2
It's a bug with Bitcoin's JSON-RPC client, I think. I get that for all commands with more than one parameter. Try using some other client (JSON-RPC PHP, for example) to do it.
sr. member
Activity: 350
Merit: 250
probiwon.com
August 05, 2010, 06:22:50 PM
#1
Code:
[email protected]:~$ ./bitcoin-0.3.8/bin/64/bitcoin getreceivedbylabel mylabel minconf=10
error: type mismatch
[email protected]:~$ ./bitcoin-0.3.8/bin/64/bitcoin getreceivedbylabel mylabel
0.000000000000000

or I did not understand the format of command?
Jump to: