So I am doing some programming and a minor thing that bugs me is the "weird" naming convention of a minority of the RPC calls.
bitcoind help
addmultisigaddress
<'["key","key"]'> [account]
backupwallet
createrawtransaction [{"txid":txid,"vout":n},...] {address:amount,...}
decoderawtransaction
dumpprivkey
getaccount
getaccountaddress
getaddressesbyaccount
getbalance [account] [minconf=1]
getblock
getblockcount
getblockhash
getblocktemplate [params]
getconnectioncount
getdifficulty
getgenerate
gethashespersec
getinfo
getmininginfo
getnewaddress [account]
getpeerinfo
getrawmempool
getrawtransaction [verbose=0]
getreceivedbyaccount [minconf=1]
getreceivedbyaddress [minconf=1]
gettransaction
getwork [data]
help [command]
importprivkey [label]
keypoolrefill
listaccounts [minconf=1]
listaddressgroupings
listreceivedbyaccount [minconf=1] [includeempty=false]
listreceivedbyaddress [minconf=1] [includeempty=false]
listsinceblock [blockhash] [target-confirmations]
listtransactions [account] [count=10] [from=0]
listunspent [minconf=1] [maxconf=9999999] ["address",...]
move [minconf=1] [comment]
sendfrom [minconf=1] [comment] [comment-to]
sendmany {address:amount,...} [minconf=1] [comment]
sendrawtransaction
sendtoaddress [comment] [comment-to]
setaccount
setgenerate [genproclimit]
settxfee
signmessage
signrawtransaction [{"txid":txid,"vout":n,"scriptPubKey":hex},...] [,...] [sighashtype="ALL"]
stop
submitblock [optional-params-obj]
validateaddress
verifymessage
walletlock
walletpassphrase
walletpassphrasechange
Generally procedure calls have a "verb". It is a command you are asking the system (any system) to do something. Getbalance ... instructing the bitcoind to get something, get what? the balance. The call getbalance is self documenting. It is clear that the call will be returning information and the information returned is the balance. Names which lack a verb are not self describing. Most of the RPC calls follow this convention, the list above can be summarized as the following verbs
add
backup
create
decode
dump
get
import
list
move
send
set
sign
stop
submit
validate
verify
There are four calls which break with that convention:
keypoolrefill
walletlock
walletpassphrase
walletpassphrasechange Of the four "walletpassphrase" is the worst. It lacks any verb and thus the call itself isn't self documenting at all (walletpassphrase what?). I suggest the four calls be renamed to fit with the standard set by the other RPC calls (verb + object of verb)
refillkeypool
lockwallet
unlockwallet
setpassphrase To avoid breaking compatibility with existing code the current RPC calls can be made deprecated aliases to the newly named ones. I know it is relatively minor but it just bugs me every time I am doing some bitcoind coding. I don't have the time to do the modifications and pull request so I am offering a bounty. 2BTC for a completed pull, and 3 BTC more when integrated into the mainline.