Author

Topic: Testing Bitcoin on Ubuntu 10.04 LTS x64 Makes System Unresponsive (Read 9457 times)

member
Activity: 60
Merit: 10
Somewhere I got the suggestion I should use -proxy=127.0.0.1:9050 in the command line, but it looks like it won't run with that setting.

That command makes Bitcoin run via TOR if that is availabe. TOR makes it impossible to trace a transaction to your IP address, since communication travels through a chain of 3 proxy servers. If TOR is not running on the same computer, it doesn't work, as you have observed.
newbie
Activity: 5
Merit: 0
Please try running with 'nice -n 19 ./bitcoin'

That seems to be doing the trick. Thanks for the suggestion.

Somewhere I got the suggestion I should use -proxy=127.0.0.1:9050 in the command line, but it looks like it won't run with that setting.

TT
newbie
Activity: 2
Merit: 0
Thanks for the prompt (and concise) replies. I am currently re-testing, and I caught one mistake I made. I was originally running Bitcoin as root. I am currently re-testing sans the root and the unresponsive system issues hasn't re-manifested itself.

I'm going to give the wiki a read and learn more about this setup (like where I can use this), but so far so good.

Cheers,
daemox
full member
Activity: 199
Merit: 696
Please try running with 'nice -n 19 ./bitcoin'
or renice +19 1234 where 1234 is the pid of the running bitcoin.

There is a bug in the released linux version which prevents it from successfully lowering its own priority.
newbie
Activity: 5
Merit: 0
I was attracted to Bitcoin by many things, and included was the statement about its running in the background when the CPU was idle. I installed 0.3.0 in Ubuntu 64-bit Maverick Meerkat (10.10), and for long periods of time it pins the CPU at 100%, according to the Conky monitor.

As the original poster noted, it is impossible to do anything else while the CPU is captured.

My CPU is an AMD Athlon 64-bit 7550 Dual Core 2511 MHz 512 KB cache.

TT
newbie
Activity: 39
Merit: 0
bitcoin manually changes the thread priorities when it generates coins, I think there is a bug in which they are switching to the MAX priority, instead of the MIN.. I myself just ripped out the whole priority changing part so that whatever I change it to, stays.. these 2 threads describe both:

https://bitcointalksearch.org/topic/bitcoin-auto-renice-ing-72
https://bitcointalksearch.org/topic/bitcoind-possibly-process-priority-bug-285

As the computer I put bitcoind, is my primary linux machine, I was unable to keep bitcoind running until making my changes..
sr. member
Activity: 252
Merit: 255
If you have a multi core processor, free up a core in the options. If you have hyper threading enabled, don't use more than half your cores. If you have a single core, you'll be just as well off purchasing or working for bitcoins because generating them will likely take a very long time.
newbie
Activity: 2
Merit: 0
Hello,

I'm interested in Bitcoin, but while generating coins it rendered my system pretty much unusable (system became very unresponsive, even after manually adjusting Bitcoin's priority down).

If there are any suggestions for getting Bitcoin to function better I'd love to hear them.

Thank you,
daemox
Jump to: